CVE-2026-47271: mcdope pam_usb · NULL Pointer Dereference
Affects mcdope pam_usbSource CVE Database V5
Not known to be exploited · CVSS 5.1 Medium : upgrade to 0.9.0 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.9.0
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade pam_usb and mcdope/pam_usb to 0.9.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| mcdopepam_usb | Affected
| Fixed in
|
GitHubmcdope/pam_usbpkg:github/mcdope/pam_usbOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in pam_usb version 0.9.0. Users and administrators should upgrade to version 0.9.0 or later to remediate this issue. Until upgraded, be aware that inducing memory pressure can cause authentication failures.
Description
CVE-2026-47271 is a NULL pointer dereference vulnerability in pam_usb versions prior to 0.9.0. The issue arises because out-of-memory guards implemented with assert() are compiled out in release builds, causing allocation functions to return NULL without checks. This leads to a crash in the PAM module when memory allocation fails, resulting in a local denial-of-service by preventing authentication via sudo or login. The vulnerability is fixed in version 0.9.0.