Skip to main content
VulnerabilityPublished Updated

CVE-2026-47323: Apache Camel · Improper Handling of Case Sensitivity

Affects Apache CamelSource CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · 19% EPSS · CVSS 9.8 Critical : upgrade to 4.18.2 or 4.14.6 as a priority.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
19.5% chance of exploitation in 30 days – higher than 97% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.18.2, 4.14.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Apache to 4.18.2 or 4.14.6.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache CamelAffected
  • >=4.15.0 <4.18.2
Fixed in
  • 4.18.2
Apache Software FoundationApache CamelAffected
  • >=3.18.0 <4.14.6
Fixed in
  • 4.14.6
MavenApache Software Foundation/org.apache.camel:camel-cxf-restpkg:maven/Apache Software Foundation/org.apache.camel:camel-cxf-restOther threatsAffected
  • >=3.18.0 <4.14.6
  • >=4.15.0 <4.18.2
Fixed in
  • 4.14.6
  • 4.18.2
Mavenorg.apache.camel/camel-corepkg:maven/org.apache.camel/camel-coreOther threatsAffected
  • 3.18.0 – 4.18.2
4 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade to Apache Camel version 4.19.0 to fully remediate this vulnerability. For those on the 4.18.x LTS stream, upgrading to 4.18.2 is recommended. For users on the 4.14.x LTS stream, upgrading to 4.14.6 addresses the issue. No other mitigations or workarounds are specified in the vendor advisory. Patch status is confirmed by vendor advisories linked, and these versions contain the official fix.

Description

Camel-CXF and Camel-Knative Message Header Injection via Missing Inbound Filtering The CXF and Knative HeaderFilterStrategy implementations (CxfRsHeaderFilterStrategy in camel-cxf-rest, CxfHeaderFilterStrategy in camel-cxf-transport, and KnativeHttpHeaderFilterStrategy in camel-knative-http) only filter outbound Camel-internal headers via setOutFilterStartsWith, while not configuring inbound filtering via setInFilterStartsWith. As a result, an unauthenticated attacker can inject Camel-internal headers (e.g. CamelExecCommandExecutable, CamelFileName) via HTTP requests to CXF-RS or CXF-SOAP endpoints. When a route forwards messages from these endpoints to header-driven components such as camel-exec or camel-file, the injected headers override configured values, enabling remote code execution or arbitrary file writes. This is the same pattern that was previously addressed in camel-undertow (CVE-2025-30177), the broader incoming-header filter (CVE-2025-27636 and CVE-2025-29891), and non-HTTP strategies (CVE-2026-40453). This issue affects Apache Camel: from 3.18.0 before 4.14.6, from 4.15.0 before 4.18.2. Users are recommended to upgrade to version 4.19.0, which fixes the issue. If users are on the 4.18.x LTS releases stream, then they are suggested to upgrade to 4.18.2. If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.6.

References

Community reviews

Loading reviews…