Skip to main content
VulnerabilityPublished

CVE-2026-47328: Linux kernel · Free of memory not on the heap

Affects Linux kernelSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.1 Medium · fixed in Ubuntu package updates : update the Ubuntu Linux linux package when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.09% chance of exploitation in 30 days – higher than 0% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.0-22.22, 6.17.0-35.35, 6.8.0-124.124
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade the Ubuntu Linux linux package to 7.0.0-22.22, 6.17.0-35.35 or 6.8.0-124.124.

Affected software

ProductAffectedFixed in
Ubuntu LinuxlinuxAffected
  • >=7.0.0 <7.0.0-22.22
Fixed in
  • 7.0.0-22.22
Ubuntu LinuxlinuxAffected
  • >=6.17.0 <6.17.0-35.35
Fixed in
  • 6.17.0-35.35
Ubuntu LinuxlinuxAffected
  • >=6.8.0 <6.8.0-124.124
Fixed in
  • 6.8.0-124.124
Ubuntuubuntu/linuxpkg:deb/ubuntu/linuxOther threatsAffected
  • =6.8.0
  • =6.17.0
  • =7.0.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restricting local user access and minimizing untrusted local user activity may reduce risk.

Description

Ubuntu Linux 6.8, 6.17 and 7.0 contain AppArmor SAUCE patches which incorrectly attempt to free a pointer which was not previously kmalloc()d, while at the same time leaking allocated memory. The bug can be triggered by an unprivileged local user and can result in the corruption of slab metadata and could lead to resource exhaustion.

References

Community reviews

Loading reviews…