Skip to main content
VulnerabilityPublished

CVE-2026-47706: strawberry · Uncontrolled Resource Consumption

Affects strawberrySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 0.315.7 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.315.7, 0.71.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade strawberry to 0.315.7; strawberry-graphql/strawberry to 0.71.0.

Affected software

ProductAffectedFixed in
strawberry-graphqlstrawberryAffected
  • >=0.71.0 <0.315.7
Fixed in
  • 0.315.7
PyPIstrawberry-graphql/strawberrypkg:pypi/strawberry-graphql/strawberryOther threatsAffected
  • <0.71.0
  • >=0.71.0 <=0.315.6
Fixed in
  • 0.71.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade strawberry-graphql to version 0.315.7 or later, where this vulnerability is patched. Patch status is confirmed by the version fix information. No additional mitigations are indicated.

Description

Strawberry GraphQL is a library for creating GraphQL APIs. In versions 0.71.0 through 0.315.6, the QueryDepthLimiter extension is vulnerable to an Application-level DOS due to a lack of cycle detection in fragment spreads. When a query contains circular fragment references the determine_depth function enters an infinite recursion, leading to a RecursionError and crashing the validation process. Version 0.315.7 patches the issue.

References

Community reviews

Loading reviews…