Skip to main content
VulnerabilityPublished

CVE-2026-48121: langchain-ai langgraphjs · Improper Neutralization of Special Elements in Data Query Logic

Affects langchain-ai langgraphjsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.7 Medium : upgrade to 1.3.1 when convenient.

Data as of 2 Nov 2026, 22:58 UTC

CVSS 3.1 base score
6.7Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.3.1
CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade langchain-ai langgraphjs to 1.3.1.

Affected software

ProductAffectedFixed in
langchain-ailanggraphjsAffected
  • <1.3.1
Fixed in
  • 1.3.1

AI-suggested

Upgrade to langgraphjs version 1.3.1 or later, where this issue is fixed. Until then, ensure that all checkpoint identifier inputs are strictly validated and coerced to strings before being passed to MongoDB queries. Reject or sanitize any non-string input to prevent injection of MongoDB operators. Applications that only use server-issued, string-typed identifiers with schema validation rejecting non-string fields are not affected and require no further action.

Description

CVE-2026-48121 is a NoSQL injection vulnerability in langchain-ai's langgraphjs library versions 1.3.0 and below. It arises because checkpoint identifiers used in MongoDB queries are not type-enforced, allowing attackers to inject MongoDB operators to bypass tenant isolation and access unauthorized checkpoint data. The issue is fixed in version 1.3.1.

References

Community reviews

Loading reviews…