Skip to main content
VulnerabilityPublished

CVE-2026-48142: F5 NGINX Open Source · Out-of-bounds Read

Affects F5 NGINX Open SourceSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.8 Medium : upgrade to 1.31.2 or 1.30.3 when convenient.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.31.2, 1.30.3, R36 P6 +1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade NGINX to 1.31.2 or 1.30.3 (Open Source); R36 P6 or 37.0.2.1 (Plus).

Affected software

ProductAffectedFixed in
F5NGINX Open SourceAffected
  • >=1.13.10 <1.31.2
Fixed in
  • 1.31.2
F5NGINX Open SourceAffected
  • >=1.30.0 <1.30.3
Fixed in
  • 1.30.3
F5NGINX PlusAffected
  • >=37.0 <37.0.2.1
  • =R36
Fixed in
  • R36 P6
  • 37.0.2.1

AI-suggested

If you cannot patch yet, consider avoiding configurations that combine source_charset utf-8 with a charset directive in the ngx_http_charset_module if feasible.

Description

NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_charset_module module. When content is served or proxied through a location block with both source_charset utf-8; and a charset directive (for example, charset koi8-r;) configured, remote, unauthenticated attackers can send requests (in conjunction with conditions beyond their control) to cause a heap buffer over-read in the NGINX worker process, leading to limited disclosure of memory or a restart. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

References

Community reviews

Loading reviews…