Skip to main content
VulnerabilityPublished

CVE-2026-48207: Apache Fory · Deserialization of Untrusted Data

Affects Apache ForySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.8 Critical : upgrade to 1.0.0 as a priority.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.0.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Apache Fory and pyfory and apache-fory to 1.0.0.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache ForyAffected
  • >=0.13.0 <1.0.0
Fixed in
  • 1.0.0
PyPIpyforypkg:pypi/pyforyOther threatsAffected
  • >=0.13.0 <1.0.0
Fixed in
  • 1.0.0
PyPIapache-forypkg:pypi/apache-foryOther threatsAffected
  • <1.0.0
Fixed in
  • 1.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Fory to version 1.0.0 or later, where the vulnerability is fixed by enforcing DeserializationPolicy validation in the ReduceSerializer. No other mitigations are specified. Patch status is confirmed by the vendor advisory stating the fix in version 1.0.0.

Description

Apache Fory versions before 1.0.0 contain a critical deserialization vulnerability (CWE-502) in the PyFory ReduceSerializer. This vulnerability allows bypassing of DeserializationPolicy validation hooks during reduce-state restoration and global-name resolution when using Python-native mode with strict mode disabled. Exploitation requires deserializing attacker-controlled data under these conditions. Upgrading to Apache Fory 1.0.0 or later mitigates the issue by enforcing DeserializationPolicy validation.

References

Community reviews

Loading reviews…