CVE-2026-48842: Roundcube Webmail · SQL Injection
Affects Roundcube WebmailSource CVE Database V5
Not known to be exploited · CVSS 8.1 High : upgrade to 1.7.1 or 1.6.16 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 1.6% chance of exploitation in 30 days – higher than 77% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.7.1, 1.6.16
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 25 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Public exploit code: GitHub proofs of concept
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Roundcube Webmail to 1.7.1 or 1.6.16.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| RoundcubeWebmail | Affected
| Fixed in
|
| RoundcubeWebmail | Affected
| Fixed in
|
GitHubroundcube/roundcubemailpkg:github/roundcube/roundcubemailOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Roundcube Webmail to version 1.6.16 or later for the 1.6.x branch, or 1.7.1 or later for the 1.7.x branch, where this vulnerability has been fixed. No other mitigation or workaround is indicated. Patch status is not explicitly confirmed in the input, but the version bounds imply official fixes in these releases.
Description
CVE-2026-48842 is a high-severity SQL injection vulnerability in Roundcube Webmail affecting versions 1.6.0 through before 1.6.16 and 1.7.0 through before 1.7.1. The flaw exists in the virtuser_query plugin and allows pre-authentication attackers to exploit a preg_replace() backslash escape bypass to execute arbitrary SQL commands. This vulnerability can lead to full compromise of confidentiality, integrity, and availability of the affected system.
References
- roundcube.net/news/2026/05/24/security-updates-1.6.16-and-1.7.1 (opens in a new tab)
- github.com/roundcube/roundcubemail/releases/tag/1.7.1 (opens in a new tab)
- github.com/roundcube/roundcubemail/commit/3406183a9976e36f992d3468f37d0e2346526ee9 (opens in a new tab)
- github.com/roundcube/roundcubemail/releases/tag/1.6.16 (opens in a new tab)
- github.com/roundcube/roundcubemail/commit/87124cc7136a48b5fa9d2b40dfead6e9dcaeaf4b (opens in a new tab)
- openwall.com/lists/oss-security/2026/06/03/17 (opens in a new tab)