Skip to main content
VulnerabilityPublished

CVE-2026-48980: mcdope pam_usb · External Initialization of Trusted Variables or Data Stores

Affects mcdope pam_usbSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.3 Medium : upgrade to 0.9.2 when convenient.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 3.1 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.9.2
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade pam_usb and mcdope/pam_usb to 0.9.2.

Affected software

ProductAffectedFixed in
mcdopepam_usbAffected
  • <0.9.2
Fixed in
  • 0.9.2
GitHubmcdope/pam_usbpkg:github/mcdope/pam_usbOther threatsAffected
  • <0.9.2
Fixed in
  • 0.9.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade pam_usb to version 0.9.2 or later, where this vulnerability has been fixed. No other mitigation is indicated by the vendor advisory. Patch status is confirmed fixed in version 0.9.2.

Description

pam_usb versions prior to 0.9.2 are vulnerable to environment variable injection via the XRDP_SESSION, DISPLAY, and TMUX variables. These variables affect local-check logic determining session locality in PAM modules running with elevated privileges. An attacker with local access can manipulate these environment variables to influence authentication decisions. This vulnerability has been fixed in version 0.9.2.

References

Community reviews

Loading reviews…