Skip to main content
VulnerabilityPublished Updated

CVE-2026-49205: thorsten phpMyFAQ · Missing Authorization

Affects thorsten phpMyFAQSource CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 6.5 Medium : upgrade to 4.1.4 when convenient.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.1.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade phpMyFAQ and thorsten/phpMyFAQ to 4.1.4.

Affected software

ProductAffectedFixed in
thorstenphpMyFAQAffected
  • <4.1.4
Fixed in
  • 4.1.4
GitHubthorsten/phpMyFAQpkg:github/thorsten/phpMyFAQOther threatsAffected
  • <4.1.4
Fixed in
  • 4.1.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade phpMyFAQ to version 4.1.4 or later, where this missing authorization issue is fixed by enforcing user permission checks on all relevant API endpoints. Until upgraded, restrict access to the shared API key to trusted users only to minimize risk.

Description

phpMyFAQ is an open source FAQ web application. Versions prior to 4.1.4 have Missing Authorization in the API CategoryController. CVE-2026-24421 addressed this in the BackupController by adding: $this->userHasPermission(PermissionType::BACKUP). The same fix was not applied to 4 other write endpoints in the public API. All 4 only call $this->hasValidToken() — which checks a shared API key header, rather than the individual user's role permissions. The following APIs are affected: POST /api/v4.0/category (CategoryController::create), POST /api/v4.0/faq (FaqController::create), PUT /api/v4.0/faq (FaqController::update), and POST /api/v4.0/question (QuestionController::create). This issue has been fixed in version 4.1.4.

References

Community reviews

Loading reviews…