CVE-2026-49255: electerm · OS Command Injection
Affects electermSource GCVE Database
Not known to be exploited · CVSS 8.8 High : upgrade to 3.11.11 soon.
Data as of 27 Oct 2026, 14:43 UTC
- Patch
- Available – fixed in 3.11.11
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 19 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade electerm to 3.11.11.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| electerm electerm | Affected
| Fixed in
|
AI-suggested
Users should upgrade electerm to version 3.11.11 or later where this vulnerability is fixed. No other mitigations are specified or required once the update is applied.
Description
CVE-2026-49255 is an OS command injection vulnerability in electerm prior to version 3.11.11. The vulnerability arises because electerm interpolates untrusted file paths into system commands such as rmrf(), mv(), and cp() without proper sanitization. A malicious SSH or SFTP server can supply crafted filenames containing shell metacharacters, leading to arbitrary command execution with the user's privileges on both POSIX and Windows systems. This can result in data exfiltration, file modification, malware installation, or denial of service. The issue is fixed in electerm version 3.11.11.