CVE-2026-49267: Apache Airflow · Improper Certificate Validation
Affects Apache AirflowSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 5.9 Medium : upgrade to 3.2.2 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.2.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 1 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Apache Airflow to 3.2.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Airflow | Affected
| Fixed in
|
PyPIapache-airflowpkg:pypi/apache-airflowOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Airflow to version 3.2.2 or later, which addresses this improper certificate validation issue in the core airflow.utils.email code path. Additionally, users who have applied the fix for the related SMTP provider vulnerability (CVE-2026-41016) should ensure their core Airflow version is also updated to 3.2.2 or later. There is no indication that temporary workarounds or configuration changes fully mitigate this issue without upgrading. Patch status is not explicitly confirmed in the advisory, but the vendor recommends upgrading to 3.2.2 or later as the remediation.
Description
Apache Airflow versions configured with smtp_starttls=True and smtp_ssl=False establish SMTP STARTTLS connections without verifying the remote server's certificate. This improper certificate validation allows a network man-in-the-middle attacker to present a self-signed certificate, causing the worker to complete the TLS handshake silently and potentially expose SMTP authentication credentials and email contents. The vulnerability affects Apache Airflow core prior to version 3.2.2 and is related to a previously addressed issue in the SMTP provider component. Users should upgrade to Apache Airflow 3.2.2 or later to mitigate this risk.