Skip to main content
VulnerabilityPublished

CVE-2026-49270: Apache ActiveMQ Broker · Exposure of Sensitive Information Through Metadata

Affects Apache ActiveMQ BrokerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.9 Medium : upgrade to 6.2.6 or 5.19.7 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.2.6, 5.19.7
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache ActiveMQ Broker and Apache ActiveMQ and Apache ActiveMQ All and Apache Software Foundation/org.apache.activemq:activemq-broker and Apache Software Foundation/org.apache.activemq:activemq-all and org.apache.activemq/activemq-broker to 6.2.6 or 5.19.7.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache ActiveMQ BrokerAffected
  • >=6.0.0 <6.2.6
Fixed in
  • 6.2.6
Apache Software FoundationApache ActiveMQ BrokerAffected
  • >=5.14.0 <5.19.7
Fixed in
  • 5.19.7
Apache Software FoundationApache ActiveMQAffected
  • >=6.0.0 <6.2.6
Fixed in
  • 6.2.6
Apache Software FoundationApache ActiveMQAffected
  • >=5.14.0 <5.19.7
Fixed in
  • 5.19.7
Apache Software FoundationApache ActiveMQ AllAffected
  • >=6.0.0 <6.2.6
Fixed in
  • 6.2.6
Apache Software FoundationApache ActiveMQ AllAffected
  • >=5.14.0 <5.19.7
Fixed in
  • 5.19.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache ActiveMQ Broker to version 5.19.7 or 6.2.6 or later, where this vulnerability is fixed. Patch status is confirmed by the vendor advisory recommending these versions. No other mitigations are specified. Patch status is confirmed by the vendor advisory recommending these versions.

Description

Apache ActiveMQ Broker versions before 5.19.7 and from 6.0.0 before 6.2.6 have a vulnerability that allows unauthenticated attackers to obtain sensitive metadata about durable topic subscriptions. This includes client identifiers, subscription names, topic destinations, and JMS selector expressions. The issue arises when brokers are configured with a network connector with syncDurableSubs set to true and respond to BrokerInfo commands without verifying authentication. Upgrading to versions 5.19.7 or 6.2.6 resolves this vulnerability.

References

Community reviews

Loading reviews…