Skip to main content
VulnerabilityPublished

CVE-2026-49272: oauthlib · Improper Authentication

Affects oauthlibSource CVE Database V5

0
Compare

Public exploit available · CVSS 8.5 High : upgrade to 4.0.1 as a priority.

Data as of 5 Nov 2026, 21:19 UTC

CVSS 3.1 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.18.5
CISA SSVC
Exploitation
Proof of concept is public or traded
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Limited control over the software or limited information exposure

CISA SSVC assessment, 2026-11-05.

Patch
Available – fixed in 4.0.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:N

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 5 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CISA SSVC: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by GitHub, Inc.

    , 161 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. CISA SSVC assessment

    proof of concept public

    , 16 minutes after disclosure

  4. In Threat Radar

    record ingested

    , 21 minutes after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA SSVC, the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade oauthlib to 4.0.1.

Affected software

ProductAffectedFixed in
oauthliboauthlibAffected
  • >=3.3.0 <4.0.1
Fixed in
  • 4.0.1

AI-suggested

Upgrade OAuthLib to version 4.0.1 or later, where the vulnerability is fixed. No other mitigations are indicated by the vendor advisory.

Description

OAuthLib versions from 3.3.0 up to but not including 4.0.1 contain an improper authentication vulnerability in the RFC 8628 device workflow. The DeviceCodeGrant.validate_token_request method does not verify the presence or validity of the device_code parameter. This allows an attacker who knows a valid client ID enabled for the device workflow to submit a missing or invalid device code and obtain a bearer token without completing device authorization. The issue is resolved in version 4.0.1.

References

Community reviews

Loading reviews…