Skip to main content
VulnerabilityPublished

CVE-2026-49373: JetBrains TeamCity · Argument Injection

Affects JetBrains TeamCitySource CVE Database V5

0
Compare

Not known to be exploited · 24% EPSS · CVSS 7.1 High : upgrade to 2026.1 soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
24.9% chance of exploitation in 30 days – higher than 97% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2026.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade TeamCity and org.jetbrains.teamcity/teamcity-server to 2026.1.

Affected software

ProductAffectedFixed in
JetBrainsTeamCityAffected
  • <2026.1
Fixed in
  • 2026.1
Mavenorg.jetbrains.teamcity/teamcity-serverpkg:maven/org.jetbrains.teamcity/teamcity-serverOther threatsAffected
  • <2026.1
Fixed in
  • 2026.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restricting access to TeamCity and limiting privileges for users who can configure Perforce connections may reduce risk.

Description

CVE-2026-49373 is a high-severity vulnerability in JetBrains TeamCity before version 2026.1 that allows remote code execution via Perforce connection settings. The vulnerability is classified under CWE-88, which relates to improper neutralization of commands or arguments. The vulnerability requires at least low privileges and no user interaction to exploit, with a high impact on confidentiality but limited impact on integrity and no impact on availability.

References

Community reviews

Loading reviews…