CVE-2026-49450: laurent22 joplin · Insufficient Verification of Data Authenticity
Affects laurent22 joplinSource CVE Database V5
Not known to be exploited · CVSS 7.1 High : upgrade to 3.7.2 soon.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.7.2
CVSS:3.1/AV:A/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 21 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade joplin and laurent22/joplin to 3.7.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| laurent22joplin | Affected
| Fixed in
|
GitHublaurent22/joplinpkg:github/laurent22/joplinOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in Joplin version 3.7.2. Users should upgrade to version 3.7.2 or later to ensure the update mechanism properly verifies the authenticity of update packages. No additional mitigation is required once updated.
Description
Joplin Desktop for Windows versions prior to 3.7.2 have a vulnerability where the update mechanism does not properly verify the authenticity of update packages. This allows an attacker controlling the update delivery path to replace update metadata and installers with malicious versions that may be unsigned or signed by an unauthorized publisher. Exploitation can lead to execution of attacker-controlled code with the user's privileges, risking compromise of notes, credentials, and local data. The issue is fixed in version 3.7.2.