Skip to main content
VulnerabilityPublished

CVE-2026-49461: py-pdf pypdf · Uncontrolled Resource Consumption

Affects py-pdf pypdfSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 6.12.2 when convenient.

Data as of 5 Nov 2026, 23:24 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.06.9
EPSS
0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.12.2
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade py-pdf pypdf to 6.12.2.

Affected software

ProductAffectedFixed in
py-pdfpypdfAffected
  • <6.12.2
Fixed in
  • 6.12.2
PyPIpypdfpkg:pypi/pypdfOther threatsAffected
  • <6.12.2
Fixed in
  • 6.12.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in pypdf version 6.12.2. Users should upgrade to version 6.12.2 or later to remediate this vulnerability. No other mitigation or temporary workaround is indicated.

Description

pypdf is a free and open-source pure-python PDF library. Prior to 6.12.2, an attacker who uses this vulnerability can craft a PDF which leads to large memory usage. This requires extracting the text of a page which contains a form XObject with self-references. This vulnerability is fixed in 6.12.2.

References

Community reviews

Loading reviews…