CVE-2026-49762: elixir · Uncontrolled Resource Consumption
Affects elixirSource CVE Database V5
Not known to be exploited · CVSS 5.1 Medium : upgrade to 1.20.1 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.20.1
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 9 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade elixir to 1.20.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| elixir-langelixir | Affected
| Fixed in
|
| elixir-langelixir | Affected
| Fixed in– |
Hexelixirpkg:hex/elixirOther threats | Affected
| Fixed in
|
GitHubelixirpkg:github/elixirOther threats | Affected
| Fixed in
|
CPE configurations (1)
cpe:2.3:a:elixir-lang:elixir:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, avoid parsing untrusted version strings or implement input validation to limit the length and format of numeric version components to prevent excessive resource consumption.
Description
Uncontrolled Resource Consumption vulnerability in the Elixir standard library's Version module allows an attacker who controls a version string to cause a denial of service through CPU and memory exhaustion. The version parser converts numeric version components (major, minor, patch and numeric pre-release/build identifiers) to integers without bounding their length. A single large all-digit component therefore forces a super-linear, non-yielding base-10 to arbitrary-precision integer conversion (String.to_integer/1, i.e. :erlang.binary_to_integer/1) that pins a BEAM scheduler, and a larger component raises an uncaught SystemLimitError that crashes the calling process. A single moderately sized string (around one megabyte) is enough; no authentication is required. This is reachable from the public entry points Version.parse/1, Version.parse!/1, Version.match?/3, Version.compare/2, and Version.parse_requirement/1, which applications routinely call on untrusted input such as HTTP parameters, dependency-manifest fields, and package metadata. This vulnerability is associated with program files lib/version.ex and program routines 'Elixir.Version.Parser':parse_digits/2. This issue affects elixir: from 0.9.3 before 1.20.1.
References
- github.com/elixir-lang/elixir/security/advisories/GHSA-w2h8-8x3g-278p (opens in a new tab)
- cna.erlef.org/cves/CVE-2026-49762.html (opens in a new tab)
- osv.dev/vulnerability/EEF-CVE-2026-49762 (opens in a new tab)
- github.com/elixir-lang/elixir/commit/c64417d72fd5c7d09e963ca3ac5fa2b140978d9e (opens in a new tab)
- github.com/elixir-lang/elixir/commit/057691722eb8cfe315f5606358954a2b173ff7a3 (opens in a new tab)
- github.com/elixir-lang/elixir/commit/64e6707233464c3e55a9ca6b44019aed25b0390a (opens in a new tab)