Skip to main content
VulnerabilityPublished Updated

CVE-2026-49948: mem0ai mem0 · Missing Authorization

Affects mem0ai mem0Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.6 High.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
mem0aimem0Affected
  • <=0.2.8
Fixed in–
GitHubmem0ai/mem0pkg:github/mem0ai/mem0Other threatsAffected
  • <=0.2.8
Fixed in–
GitHubmem0pkg:github/mem0Other threatsAffected
  • <=0.2.8
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix for this vulnerability exists and was introduced in commit ae7f406. Users should upgrade mem0 to a version later than 0.2.8 that includes this fix. Until upgraded, restrict API key distribution and monitor for unauthorized configuration changes. Patch status is not explicitly confirmed in the advisory, so verify the vendor's repository or advisory for the exact patched version and apply the official fix.

Description

Mem0 versions through 0.2.8, fixed in commit ae7f406, contain a missing authorization vulnerability in the self-hosted server component where the POST /configure endpoint modifies global LLM provider and embedder configuration but only verifies authentication via JWT or X-API-Key without validating the caller's role. Any authenticated user holding a distributed API key can redirect all LLM and embedder traffic to an attacker-controlled server, with the malicious configuration persisted to PostgreSQL and surviving server restarts to affect all users and API keys on the instance.

References

Community reviews

Loading reviews…