Skip to main content
VulnerabilityPublished Updated

CVE-2026-49959: nesquena hermes-webui · OS Command Injection

Affects nesquena hermes-webuiSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 0.51.311 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 60% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.51.311
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade nesquena/hermes-webui and hermes-webui to 0.51.311.

Affected software

ProductAffectedFixed in
nesquenahermes-webuiAffected
  • <0.51.311
Fixed in–
GitHubnesquena/hermes-webuipkg:github/nesquena/hermes-webuiOther threatsAffected
  • <0.51.311
Fixed in
  • 0.51.311
GitHubhermes-webuipkg:github/hermes-webuiOther threatsAffected
  • <0.51.311
Fixed in
  • 0.51.311

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Hermes WebUI to version 0.51.311 or later once available. Until then, restrict access to trusted users only and monitor for suspicious activity related to Git operations within the application.

Description

Hermes WebUI before version 0.51.311 contains a remote code execution vulnerability that allows authenticated attackers to execute arbitrary commands by placing malicious executable Git configuration in a workspace repository's .git/config file. Attackers can exploit Git subprocess invocations in api/workspace_git.py through vectors such as core.fsmonitor during git status, protocol.ext.allow with ext:: remotes during git fetch, credential.helper, core.askPass, core.gitProxy, or inherited environment variables including GIT_SSH_COMMAND to achieve arbitrary command execution on the host running the application.

References

Community reviews

Loading reviews…