CVE-2026-50127: WeblateOrg weblate · Server-Side Request Forgery (SSRF)
Affects WeblateOrg weblateSource CVE Database V5
Not known to be exploited · CVSS 5.9 Medium : upgrade to 2026.6 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2026.6
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade weblate and weblateorg/weblate to 2026.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| WeblateOrgweblate | Affected
| Fixed in
|
GitHubweblateorg/weblatepkg:github/weblateorg/weblateOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Weblate to version 2026.6 or later, where this vulnerability has been patched. No other official remediation or temporary fixes are documented. Patch status is not explicitly stated but the vendor has fixed the issue in version 2026.6.
Description
A Server-Side Request Forgery (SSRF) vulnerability exists in Weblate versions from 5.15 up to but not including 2026.6. The issue arises because the VCS_RESTRICT_PRIVATE setting did not correctly handle certain transitional IPv6 ranges, multicast addresses, and some semi-private IPv4 ranges, allowing bypass of private network restrictions. This vulnerability has been addressed in version 2026.6.