Skip to main content
VulnerabilityPublished Updated

CVE-2026-50166: kumahq kuma · Improper Certificate Validation

Affects kumahq kumaSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.5 Medium : upgrade to 2.7.26 when convenient.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 4.0 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.7.26, 2.13.7, 2.12.11 +2
CVSS:4.0/AV:A/AC:H/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
kumahqkumaAffected
  • <2.7.26
Fixed in
  • 2.7.26
GitHubkumahq/kumapkg:github/kumahq/kumaOther threatsAffected
  • <2.7.26
  • <2.9.16
  • <2.11.14
  • <2.12.11
  • <2.13.7
Fixed in
  • 2.7.26
  • 2.9.16
  • 2.11.14
  • 2.12.11
  • 2.13.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Kuma to versions 2.7.26, 2.9.16, 2.11.14, 2.12.11, or 2.13.7 or later, where this issue is fixed. Ensure that kumactl profiles configured for HTTPS control planes include the --ca-cert-file option to enable TLS peer verification. No other mitigation is required once upgraded.

Description

Kuma versions prior to 2.7.26, 2.9.16, 2.11.14, 2.12.11, and 2.13.7 contain an improper certificate validation vulnerability. When a kumactl profile is manually configured for an HTTPS control plane without specifying --ca-cert-file, TLS peer verification is disabled. This causes API tokens to be sent over an unverified connection, allowing a network attacker to intercept tokens and impersonate users or administrators. The default local profile is not affected as it uses plain HTTP. The issue is fixed in the specified versions.

References

Community reviews

Loading reviews…