Skip to main content
VulnerabilityPublished

CVE-2026-50203: Apache Airflow SFTP provider · Path Traversal

Affects Apache Airflow SFTP providerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical : upgrade to 5.8.1 as a priority.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.8.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache Airflow SFTP provider and apache-airflow-providers-sftp to 5.8.1.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache Airflow SFTP providerAffected
  • <5.8.1
Fixed in
  • 5.8.1
PyPIapache-airflow-providers-sftppkg:pypi/apache-airflow-providers-sftpOther threatsAffected
  • <5.8.1
Fixed in
  • 5.8.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade the Apache Airflow SFTP provider to version 5.8.1 or later to remediate this vulnerability. No other official remediation or temporary fixes are indicated. Deployments should avoid downloading directories from untrusted SFTP servers until patched.

Description

A critical path traversal vulnerability (CWE-22) exists in Apache Airflow SFTP provider versions prior to 5.8.1. This vulnerability allows a malicious or compromised remote SFTP server to write files outside the intended local directory by using crafted directory-entry names. Exploitation does not require any Airflow account, making any deployment that downloads directories from an untrusted SFTP server vulnerable. Upgrading to version 5.8.1 or later mitigates this issue.

References

Community reviews

Loading reviews…