CVE-2026-50268: SteeltoeOSS Steeltoe.Configuration.Encryption · Plaintext Storage of a Password
Affects SteeltoeOSS Steeltoe.Configuration.EncryptionSource CVE Database V5
Not known to be exploited · CVSS 1.9 Low : upgrade to 4.2.0 when convenient.
Data as of 30 Oct 2026, 20:25 UTC
- EPSS
- 0.04% chance of exploitation in 30 days – higher than 0% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.2.0
CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 17 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade SteeltoeOSS Steeltoe.Configuration.Encryption to 4.2.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SteeltoeOSSSteeltoe.Configuration.Encryption | Affected
| Fixed in
|
NuGetSteeltoeOSS/steeltoe.configuration.encryptionpkg:nuget/SteeltoeOSS/steeltoe.configuration.encryptionOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Steeltoe.Configuration.Encryption to version 4.2.0 or later, where the issue is fixed and OAEP encryption is correctly enabled. Until upgrading, users should be aware that selecting OAEP does not provide the intended encryption strength.
Description
Steeltoe.Configuration.Encryption versions 4.0.0 through 4.1.0 contain a vulnerability where configuring RSA encryption with the OAEP algorithm does not actually enable OAEP. Instead, due to an incorrect transformation string in the BouncyCastle library, the OAEP setting falls back to using PKCS#1 v1.5 encryption, which is less secure. This issue is fixed in version 4.2.0.