CVE-2026-50523: Microsoft PowerShell 7.4 · Command Injection
Affects Microsoft PowerShell 7.4Source CVE Database V5
Not known to be exploited · CVSS 7.8 High : upgrade to 7.4.19.0 soon.
Data as of 26 Oct 2026, 13:47 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.4.19.0, 7.5.10.0, 7.6.5
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:CExploitation evidence
Disclosed: evidence found.
CVE published 14 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade PowerShell to 7.4.19.0 (7.4) or 7.5.10.0 (7.5) or 7.6.5 (7.6).
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| MicrosoftPowerShell 7.4 | Affected
| Fixed in
|
| MicrosoftPowerShell 7.5 | Affected
| Fixed in
|
| MicrosoftPowerShell 7.6 | Affected
| Fixed in
|
NuGetmicrosoft.powershell.sdkpkg:nuget/microsoft.powershell.sdkOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
An official fix is available from Microsoft. Users should apply the security updates that upgrade affected PowerShell versions to fixed releases (7.4.19.0 or later, 7.5.10.0 or later, and 7.6.5 or later). Refer to the Microsoft advisory at https://msrc.microsoft.com/update-guide/vulnerability/CVE-2026-50523 for detailed patching instructions.
Description
CVE-2026-50523 is a command injection vulnerability in Microsoft PowerShell 7.4 that allows an authorized local attacker to execute arbitrary code. The flaw involves improper neutralization of special elements used in commands. This vulnerability affects specific versions of PowerShell 7.4, 7.5, and 7.6. An official fix is available from Microsoft.