Skip to main content
VulnerabilityPublished Updated

CVE-2026-50627: Apache CXF · Authentication Bypass by Alternate Name

Affects Apache CXFSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical · fixed in 4.2.2 : patch Apache CXF as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
4.5% chance of exploitation in 30 days – higher than 91% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.2.2, 4.1.7, 3.6.12
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache to 4.2.2, 4.1.7 or 3.6.12.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache CXFAffected
  • >=4.2.0 <4.2.2
Fixed in
  • 4.2.2
Apache Software FoundationApache CXFAffected
  • >=4.0.0 <4.1.7
Fixed in
  • 4.1.7
Apache Software FoundationApache CXFAffected
  • <3.6.12
Fixed in
  • 3.6.12
MavenApache Software Foundation/org.apache.cxf:cxf-rt-rs-security-oauth2pkg:maven/Apache Software Foundation/org.apache.cxf:cxf-rt-rs-security-oauth2Other threatsAffected
  • >=4.2.0 <4.2.2
  • >=4.0.0 <4.1.7
  • <3.6.12
Fixed in
  • 4.2.2
  • 4.1.7
  • 3.6.12

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Apache CXF versions 4.2.2, 4.1.7, and 3.6.12. Users should upgrade to these versions to remediate the vulnerability. According to the Red Hat advisory, no effective mitigation other than upgrading is currently available or meets their criteria for ease of use and stability. Therefore, applying the official patch is the recommended remediation.

Description

The JwtAccessTokenValidator class in Apache CXF fails to validate the 'aud' (Audience) claims of incoming JWT access tokens. This allows a JWT issued for one Resource Server to be successfully replayed against a completely different Resource Server, leading to Token Confusion/Routing attacks. Users are recommended to upgrade to versions 4.2.2 or 4.1.7 or 3.6.12, which fixes this issue.

References

Community reviews

Loading reviews…