CVE-2026-50749: Apache Answer · Incorrect Authorization
Affects Apache AnswerSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.0.2 when convenient.
Data as of 3 Nov 2026, 10:58 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.0.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 5 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade org.apache.answer/answer to 2.0.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Answer | Affected
| Fixed in– |
Mavenorg.apache.answer/answerpkg:maven/org.apache.answer/answerOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Answer to version 2.0.2 or later, where the authorization check on the reject operation is properly implemented. No other mitigations are specified. Patch status is confirmed by the vendor's recommendation to upgrade.
Description
CVE-2026-50749 is an improper authorization vulnerability in Apache Answer affecting versions prior to 2.0.2. Authenticated users without review permissions can reject arbitrary pending edit-revisions due to a missing authorization check. The issue is fixed in version 2.0.2.