CVE-2026-51082: pve-manager · Race Condition
Affects pve-managerSource CVE Database V5
Not known to be exploited · CVSS 7.2 High · fixed in 9.1.9 : patch pve-manager soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.1.9, 8.4.19, 9.1.7 +3
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 17 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade proxmox/pve-manager to 9.1.9 or 8.4.19; proxmox/qemu-server to 9.1.7 or 8.4.7; proxmox/pve-container to 6.1.3 or 5.3.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Proxmoxproxmox/pve-managerpkg:deb/proxmox/pve-managerOther threats | Affected
| Fixed in
|
Proxmoxproxmox/qemu-serverpkg:deb/proxmox/qemu-serverOther threats | Affected
| Fixed in
|
Proxmoxproxmox/pve-containerpkg:deb/proxmox/pve-containerOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, restrict access to the vncproxy API to trusted users only and avoid concurrent VNC session establishment by multiple users where possible.
Description
A race condition between the vncproxy and vncwebsocket API calls in Proxmox Virtual Environment (PVE) 9.x pve-manager before 9.1.9 and 8.x before 8.4.19; qemu-server 9.x before 9.1.7 and 8.x before 8.4.7; and pve-container before 6.1.3 (PVE 9.x) and before 5.3.4 (PVE 8.x) allows an attacker with privileges to call "vncproxy" to hijack a VNC session that is established in parallel by a different user for a different VM.