CVE-2026-5160: github.com/yuin/goldmark/renderer/html · Cross-site Scripting (XSS)
Affects github.com/yuin/goldmark/renderer/htmlSource CVE Database V5
Not known to be exploited · CVSS 5.1 Medium : upgrade to 1.7.17 when convenient.
Data as of 30 Oct 2026, 11:34 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.7.17
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:L/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 15 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 24 Oct 2026.
What to do
Upgrade github.com/yuin/goldmark/renderer/html and github.com/yuin/goldmark to 1.7.17.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| github.com/yuin/goldmark/renderer/html | Affected
| Fixed in
|
Gogithub.com/yuin/goldmarkpkg:golang/github.com/yuin/goldmarkOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
In the meantime, consider applying input sanitization or additional URL validation layers externally if feasible.
Description
A Cross-site Scripting (XSS) vulnerability exists in github.com/yuin/goldmark/renderer/html versions before 1.7.17. The issue arises from improper ordering of URL validation and normalization, allowing attackers to bypass protocol filtering by encoding dangerous schemes with HTML5 named character references. This can lead to arbitrary script execution in applications rendering the affected URLs. The vulnerability has a medium severity with a CVSS score of 5.1.