CVE-2026-51922: agentscope · Code Injection
Affects agentscopeSource CVE Database V5
Not known to be exploited · CVSS 9.8 Critical : upgrade to 1.0.20 as a priority.
Data as of 26 Oct 2026, 12:29 UTC
- EPSS
- 1.1% chance of exploitation in 30 days – higher than 66% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.0.20
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 2 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade agentscope to 1.0.20.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
PyPIagentscopepkg:pypi/agentscopeOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, restrict access to the vulnerable entry points and monitor for suspicious activity related to command execution attempts.
Description
agentscope version 1.0.20 and earlier contains a critical code injection vulnerability in the execute_shell_command function. This flaw allows an attacker to execute arbitrary code or commands if they can reach the vulnerable entry point. The vulnerability has a CVSS score of 9.8, indicating a high severity with network attack vector, no privileges required, and no user interaction needed.