CVE-2026-5245: Cesanta Mongoose · Stack-based Buffer Overflow
Affects Cesanta MongooseSource CVE Database V5
Public exploit available · CVSS 6.3 Medium · fixed in 7.21 : patch Cesanta Mongoose as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.21
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 2 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| CesantaMongoose | Affected
| Fixed in– |
GitHubcesanta/mongoosepkg:github/cesanta/mongooseOther threats | Affected
| Fixed in– |
CPE configurations (1)
cpe:2.3:a:cesanta:mongoose:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
An official fix is available in Cesanta Mongoose version 7.21. Users should upgrade to this version to remediate the vulnerability. The vendor has provided a patch and recommends upgrading the affected component. No additional mitigation steps are indicated by the vendor advisory.
Description
CVE-2026-5245 is a stack-based buffer overflow vulnerability in the handle_mdns_record function of the mongoose.c file in Cesanta Mongoose versions up to 7.20. This vulnerability allows remote attackers to cause a buffer overflow by manipulating the buf argument. Exploitation is considered difficult and requires a high degree of complexity. The vendor has released version 7.21 to address this issue with an official patch. Users of affected versions should upgrade to the fixed version to mitigate the risk.
References
- vuldb.com/vuln/354826 (opens in a new tab)
- vuldb.com/vuln/354826/cti (opens in a new tab)
- vuldb.com/submit/770103 (opens in a new tab)
- github.com/cesanta/mongoose/commit/0d882f1b43ff2308b7486a56a9d60cd6dba8a3f1 (opens in a new tab)
- github.com/cesanta/mongoose/releases/tag/7.21 (opens in a new tab)
- github.com/cesanta/mongoose/ (opens in a new tab)