CVE-2026-52719: Red Hat Enterprise Linux 10 · Out-of-bounds Read
Affects Red Hat Enterprise Linux 10Source CVE Database V5
Not known to be exploited · CVSS 7.1 High.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 15 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Red Hat Enterprise Linux 10gstreamer1-plugins-bad-free | Affected– | Fixed in– |
| Red Hat Enterprise Linux 10.0 Extended Update Supportgstreamer1-plugins-bad-free | Affected– | Fixed in– |
| Red Hat Enterprise Linux 9gstreamer1-plugins-bad-free | Affected– | Fixed in– |
| Red Hat Enterprise Linux 9.4 Update Services for SAP Solutionsgstreamer1-plugins-bad-free | Affected– | Fixed in– |
| Red Hat Enterprise Linux 9.6 Extended Update Supportgstreamer1-plugins-bad-free | Affected– | Fixed in– |
| Red Hat Enterprise Linux 6gstreamer-plugins-bad-free | Affected– | Fixed in– |
AI-suggested
Red Hat has released an official security update for the gstreamer1-plugins-bad-free package that addresses this vulnerability. Users should apply the update to versions 10.2.4 or later as provided in Red Hat Advisory RHSA-2026:36749. Detailed update instructions are available at https://access.redhat.com/articles/11258. Applying this update fully mitigates the vulnerability. No additional workarounds or mitigations are indicated by the vendor.
Description
An out-of-bounds read vulnerability was found in the VA JPEG decoder in GStreamer's gst-plugins-bad. The JPEG parser reads a segment length value from the bitstream without validating it against available data. A remote attacker could trick a user into opening a specially crafted JPEG file, causing downstream parsing to read beyond the provided input buffer, leading to a crash or potential information disclosure.
References
- access.redhat.com/errata/RHSA-2026:36749 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:36834 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:47070 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:47071 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:47717 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-52719 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2486353 (opens in a new tab)
- gitlab.freedesktop.org/gstreamer/gstreamer/-/work_items/5104 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-52719.json (opens in a new tab)