Skip to main content
VulnerabilityPublished Updated

CVE-2026-52720: Red Hat Enterprise Linux 10 · Heap-based Buffer Overflow

Affects Red Hat Enterprise Linux 10Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Red Hat Enterprise Linux 10gstreamer1-plugins-bad-freeAffected–Fixed in–
Red Hat Enterprise Linux 10.0 Extended Update Supportgstreamer1-plugins-bad-freeAffected–Fixed in–
Red Hat Enterprise Linux 7 Extended Lifecycle Supportgstreamer1-plugins-bad-freeAffected–Fixed in–
Red Hat Enterprise Linux 7 Extended Lifecycle Supportgstreamer-plugins-bad-freeAffected–Fixed in–
Red Hat Enterprise Linux 8gstreamer1-plugins-bad-freeAffected–Fixed in–
Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Supportgstreamer1-plugins-bad-freeAffected–Fixed in–

AI-suggested

Red Hat has released official security updates for the gstreamer1-plugins-bad-free package that address this vulnerability. Users should apply the updates to versions 10.2.4 or later for Red Hat Enterprise Linux 10 and 9.8.1 or later for Red Hat Enterprise Linux 9. Detailed update instructions are available in Red Hat's advisory and knowledge base article. No additional mitigation is required once the update is applied.

Description

CVE-2026-52720 is a heap-based buffer overflow vulnerability in the GStreamer librfb plugin used by Red Hat Enterprise Linux 9 and 10. The flaw arises from improper rectangle bounds checking in the VNC client, allowing a malicious VNC server to send a rectangle extending beyond the framebuffer. This can lead to an out-of-bounds heap write, potentially causing a crash or remote code execution if a user connects to a malicious server. Red Hat has released security updates addressing this issue in versions 10.2.4 and 9.8.1 of the affected packages.

References

Community reviews

Loading reviews…