Skip to main content
VulnerabilityPublished

CVE-2026-52724: kumahq kuma · Improper Certificate Validation

Affects kumahq kumaSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.8 Medium · fixed in 2.13.7 : update kumahq kuma when convenient.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 4.0 base score
5.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.13.7, 2.12.11, 2.11.14 +2
CVSS:4.0/AV:A/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
kumahqkumaAffected
  • >=2.13.0 <2.13.7
Fixed in
  • 2.13.7
kumahqkumaAffected
  • >=2.12.0 <2.12.11
Fixed in
  • 2.12.11
kumahqkumaAffected
  • >=2.10.0 <2.11.14
Fixed in
  • 2.11.14
kumahqkumaAffected
  • >=2.8.0 <2.9.16
Fixed in
  • 2.9.16
kumahqkumaAffected
  • <2.7.26
Fixed in
  • 2.7.26
GitHubkumahq/kumapkg:github/kumahq/kumaOther threatsAffected
  • <2.7.26
  • >=2.8.0 <2.9.16
  • >=2.10.0 <2.11.14
  • >=2.12.0 <2.12.11
  • >=2.13.0 <2.13.7
Fixed in
  • 2.7.26
  • 2.9.16
  • 2.11.14
  • 2.12.11
  • 2.13.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to Kuma versions 2.7.26, 2.9.16, 2.11.14, 2.12.11, or 2.13.7 or later, where this issue is fixed. For deployments not using the standard Kubernetes installation methods, ensure that TLS peer verification is enabled by supplying the --ca-cert-file flag or setting the KUMA_CONTROL_PLANE_CA_CERT environment variable. Standard Kubernetes installations using kumactl install control-plane or the official Helm chart are not affected and require no additional action.

Description

Kuma is a modern Envoy-based service mesh that can run on every cloud across both Kubernetes and VMs. Prior to 2.7.26, 2.9.16, 2.11.14, 2.12.11, and 2.13.7, Universal mode kuma-dp connections to an HTTPS control plane disable TLS peer verification when --ca-cert-file is not supplied and KUMA_CONTROL_PLANE_CA_CERT is unset. The dataplane authentication token is sent over the unverified connection, allowing an on-path attacker to intercept the token, impersonate the control plane, inject a forged bootstrap configuration, and take over the proxy. Standard Kubernetes installations created by kumactl install control-plane or the official Helm chart are unaffected because the mutating admission webhook injects KUMA_CONTROL_PLANE_CA_CERT into each sidecar. This issue is fixed in versions 2.7.26, 2.9.16, 2.11.14, 2.12.11, and 2.13.7.

References

Community reviews

Loading reviews…