CVE-2026-52745: 1Panel-dev CordysCRM · SQL Injection
Affects 1Panel-dev CordysCRMSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 1.7.0 when convenient.
Data as of 2 Nov 2026, 10:58 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.7.0
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 18 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade CordysCRM and 1panel-dev/CordysCRM to 1.7.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| 1Panel-devCordysCRM | Affected
| Fixed in
|
GitHub1panel-dev/CordysCRMpkg:github/1panel-dev/CordysCRMOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade CordysCRM to version 1.7.0 or later, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated.
Description
CVE-2026-52745 is a medium severity SQL injection vulnerability in CordysCRM versions prior to 1.7.0. It affects the POST /account-pool/page endpoint, allowing an authenticated user with MODULE_SETTING:UPDATE permission to inject crafted input into a dynamic SQL ORDER BY clause without proper validation. This can lead to time-based blind SQL injection, enabling attackers to confirm database expression execution, infer metadata and sensitive data, and cause database delays that degrade service. The issue is fixed in version 1.7.0.
References
- github.com/1Panel-dev/CordysCRM/security/advisories/GHSA-xrcr-hj37-q83j (opens in a new tab)
- github.com/1Panel-dev/CordysCRM/pull/2418 (opens in a new tab)
- github.com/1Panel-dev/CordysCRM/commit/b5b9272c016550d80a789fd8ffbf3d5a4c4bab52 (opens in a new tab)
- github.com/1Panel-dev/CordysCRM/releases/tag/v1.7.0 (opens in a new tab)