Skip to main content
VulnerabilityPublished Updated

CVE-2026-52845: caddyserver caddy · Improper Authentication

Affects caddyserver caddySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.1 High : upgrade to 2.11.4 soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.11.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade caddy and caddyserver/caddy to 2.11.4.

Affected software

ProductAffectedFixed in
caddyservercaddyAffected
  • <2.11.4
Fixed in
  • 2.11.4
GitHubcaddyserver/caddypkg:github/caddyserver/caddyOther threatsAffected
  • <2.11.4
Fixed in
  • 2.11.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in caddyserver caddy version 2.11.4. Users should upgrade to version 2.11.4 or later to remediate this issue. No other vendor advisories indicate alternative mitigations or that no action is required. Patch status is confirmed by the vendor advisory. There is no indication that this is a cloud service; thus, manual upgrade is required.

Description

Caddy is an extensible server platform that uses TLS by default. Prior to 2.11.4, forward_auth copy_headers deletes the exact client-supplied identity header before copying the trusted value from the auth gateway. But when the request later goes through php_fastcgi, Caddy normalizes HTTP headers into CGI variables by replacing - with _. This lets a client send an underscore alias that survives the forward_auth delete step but becomes the same PHP/FastCGI variable. Result: a remote client can inject or sometimes override identity/group headers trusted by PHP/FastCGI applications behind Caddy. This vulnerability is fixed in 2.11.4.

References

Community reviews

Loading reviews…