Skip to main content
VulnerabilityPublished Updated

CVE-2026-52964: Linux kernel · ALSA: usb-audio: Bound MIDI 2.0 endpoint descriptor scans

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 5.5 Medium · patch available : update Linux kernel when convenient.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux@7.0.0-27.27?arch=source&distro=resoluteOther threatsAffected
  • 6.17.0-5.5 – 7.0.0-27.27
17 affected builds
Fixed in–
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws@7.0.0-1008.8?arch=source&distro=resoluteOther threatsAffected
  • 6.17.0-1002.2 – 7.0.0-1008.8
9 affected builds
Fixed in–
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure@7.0.0-1009.9?arch=source&distro=resoluteOther threatsAffected
  • 6.17.0-1003.3 – 7.0.0-1009.9
10 affected builds
Fixed in–
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde@7.0.0-1008.8?arch=source&distro=resoluteOther threatsAffected
  • 7.0.0-1003.3 – 7.0.0-1008.8
4 affected builds
Fixed in–
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp@7.0.0-1007.7?arch=source&distro=resoluteOther threatsAffected
  • 6.17.0-1002.2 – 7.0.0-1007.7
8 affected builds
Fixed in–
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke@7.0.0-1002.3?arch=source&distro=resoluteOther threatsAffected
  • =7.0.0-1002.3
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied to affected Linux kernel versions. The vendor advisory from Ubuntu confirms fixes in updated kernel releases. Users should update to kernel versions 6.8.0-136.136 or later, or the corresponding fixed versions listed in the advisory. No additional mitigations are specified or required.

Description

A vulnerability in the Linux kernel's ALSA usb-audio MIDI 2.0 endpoint parser was resolved. The parser improperly validates descriptor lengths, allowing a malformed USB MIDI 2.0 device to cause out-of-bounds reads during endpoint descriptor scanning. This flaw could lead to denial of service by crashing the system. The issue affects multiple specific Linux kernel versions and has been fixed in later releases.

References

Community reviews

Loading reviews…