Skip to main content
VulnerabilityPublished

CVE-2026-5302: CoolerControl coolercontrold · Permissive Cross-domain Policy with Untrusted Domains

Affects CoolerControl coolercontroldSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.3 Medium : upgrade to 4.0.0 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.0.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade CoolerControl coolercontrold to 4.0.0.

Affected software

ProductAffectedFixed in
CoolerControlcoolercontroldAffected
  • >=2.0.0 <4.0.0
Fixed in
  • 4.0.0

AI-suggested

If you cannot patch yet, consider restricting or disabling CORS policies on the affected service to limit cross-origin requests to trusted domains only. Avoid visiting untrusted websites while using affected versions. No vendor advisory states that no action is required or that the issue is already mitigated.

Description

CVE-2026-5302 is a medium severity vulnerability in CoolerControl's coolercontrold version 2.0.0 and earlier, caused by a permissive Cross-Origin Resource Sharing (CORS) policy that allows unauthenticated remote attackers to read data and send commands via malicious websites. This misconfiguration falls under CWE-942, indicating overly permissive cross-domain policies involving untrusted domains. The vulnerability enables attackers to bypass same-origin policy restrictions, potentially leading to unauthorized information disclosure and command execution on the affected service.

References

Community reviews

Loading reviews…