CVE-2026-53120: Linux kernel · PCI: use generic driver_override infrastructure
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.8 High · patch available : patch Linux kernel soon.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 24 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux@7.0.0-28.28?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws@7.0.0-1008.8?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure@7.0.0-1009.9?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde@7.0.0-1008.8?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp@7.0.0-1008.8?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke@7.0.0-1003.4?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied promptly. The vendor advisory from Ubuntu confirms that updating to linux-aws kernel versions 7.0.0-28.28 or later resolves this issue. After applying the update, a system reboot is required. Due to an ABI change, recompilation and reinstallation of third-party kernel modules may be necessary. Follow the vendor's update instructions carefully.
Description
A use-after-free vulnerability in the Linux kernel's PCI subsystem was resolved by adopting the generic driver_override infrastructure to ensure proper locking. The flaw occurred when the bus' match() callback was called without holding the device lock, leading to unsafe access of the driver_override field. This vulnerability affects multiple linux-aws kernel versions prior to 7.0.0-28.28 and related releases. The vulnerability has a CVSS score of 7.8 and impacts confidentiality, integrity, and availability. A patch is available and should be applied to mitigate the issue.
References
- ubuntu.com/security/CVE-2026-53120 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-53120 (opens in a new tab)
- git.kernel.org/linus/10a4206a24013be4d558d476010cbf2eb4c9fa64 (opens in a new tab)
- ubuntu.com/security/notices/USN-8566-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8568-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8569-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8593-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8603-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8618-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8663-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8664-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-1 (opens in a new tab)