Skip to main content
VulnerabilityPublished Updated

CVE-2026-53174: Linux kernel · ovl: keep err zero after successful ovl_cache_get()

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 7.8 High : upgrade to 7.0.0-1008.8 soon.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.0-1008.8
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu linux-oem-7.0 package to 7.0.0-1008.8.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux@7.0.0-28.28?arch=source&distro=resoluteOther threatsAffected
  • 6.17.0-5.5 – 7.0.0-28.28
18 affected builds
Fixed in–
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws@7.0.0-1008.8?arch=source&distro=resoluteOther threatsAffected
  • 6.17.0-1002.2 – 7.0.0-1008.8
9 affected builds
Fixed in–
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure@7.0.0-1009.9?arch=source&distro=resoluteOther threatsAffected
  • 6.17.0-1003.3 – 7.0.0-1009.9
10 affected builds
Fixed in–
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde@7.0.0-1008.8?arch=source&distro=resoluteOther threatsAffected
  • 7.0.0-1003.3 – 7.0.0-1008.8
4 affected builds
Fixed in–
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp@7.0.0-1008.8?arch=source&distro=resoluteOther threatsAffected
  • 6.17.0-1002.2 – 7.0.0-1008.8
9 affected builds
Fixed in–
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke@7.0.0-1003.4?arch=source&distro=resoluteOther threatsAffected
  • =7.0.0-1002.3
  • =7.0.0-1003.4
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

An official patch is available and included in updated Linux kernel packages for Ubuntu 26.04 LTS and related releases. Users should apply the kernel updates and reboot their systems to ensure the vulnerability is remediated. Due to an ABI change, third-party kernel modules must be recompiled and reinstalled after updating. No additional mitigation steps are required beyond applying the official updates.

Description

A vulnerability in the Linux kernel overlay filesystem (ovl) was resolved, where the function ovl_iterate_merged() incorrectly stored a truncated cache pointer as a non-zero error code after a successful ovl_cache_get() call. This could lead to erroneous error handling. The issue affects multiple Linux kernel versions prior to various 7.0.0-xx releases. The vulnerability has a CVSS score of 7.8 and is rated medium severity. A patch is available and included in updated Linux kernel packages for Ubuntu 26.04 LTS and related releases.

References

Community reviews

Loading reviews…