CVE-2026-53179: Linux kernel · staging: rtl8723bs: fix buffer over-read in rtw_update_protection
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.1 High · fixed in 7.0.0-31.31~24.04.1 : patch Linux kernel soon.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.0.0-31.31~24.04.1, 7.0.0-31.31, 7.0.0-1012.12 +7
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 25 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been released in Linux kernel versions 7.0.0-31.31 and later. Users of affected linux-hwe-edge kernel versions should upgrade to these fixed versions to remediate the vulnerability. No additional mitigations are indicated by the vendor advisory.
Description
A buffer over-read vulnerability was identified and fixed in the Linux kernel's rtl8723bs staging driver. The function rtw_update_protection was called with a pointer offset into the ies buffer but used the full ie_length, potentially causing a buffer over-read. This flaw affects multiple Linux kernel versions and has been addressed in fixed releases starting with version 7.0.0-31.31. The vulnerability has a CVSS score of 7.1, indicating medium severity, with potential impacts on confidentiality and availability. No known exploits are reported in the wild. A patch is available and should be applied to affected systems.
References
- ubuntu.com/security/CVE-2026-53179 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-53179 (opens in a new tab)
- git.kernel.org/linus/514ab98364595007d4557ecc85d7e5f012c504d3 (opens in a new tab)
- git.kernel.org/stable/c/303f65af819f6d5aa302e82bce72b57a8575faea (opens in a new tab)
- git.kernel.org/stable/c/514ab98364595007d4557ecc85d7e5f012c504d3 (opens in a new tab)
- git.kernel.org/stable/c/735dabdf21561a24d8bcae456c9c32f7f961a029 (opens in a new tab)
- ubuntu.com/security/notices/USN-8726-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8727-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-1 (opens in a new tab)