CVE-2026-53241: Linux kernel · ALSA: seq: dummy: fix UMP event stack overread
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 5.5 Medium · fixed in 7.0.0-31.31~24.04.1 : update Linux kernel when convenient.
Data as of 26 Oct 2026, 12:55 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.0.0-31.31~24.04.1, 7.0.0-31.31, 7.0.0-1012.12 +7
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 25 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available and has been released in Linux kernel versions 7.0.0-31.31 and later for the affected distributions. Users should upgrade to these fixed versions to remediate the vulnerability. No additional mitigation actions are required beyond applying the official patch.
Description
A vulnerability in the Linux kernel's ALSA dummy sequencer port was fixed to prevent a UMP event stack overread. The issue involved copying a larger UMP event into a smaller legacy stack buffer, causing reads beyond the buffer boundary. This flaw was addressed by using a union to preserve the full UMP packet size during event forwarding. The vulnerability affects specific Linux kernel versions and has been fixed in later releases. The CVSS score is 5.5, indicating medium severity with potential availability impact but no confidentiality or integrity impact.
References
- ubuntu.com/security/CVE-2026-53241 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-53241 (opens in a new tab)
- git.kernel.org/linus/2b5ff4db5d7aa5b981d966df02e687f79ad7b311 (opens in a new tab)
- git.kernel.org/stable/c/2b5ff4db5d7aa5b981d966df02e687f79ad7b311 (opens in a new tab)
- git.kernel.org/stable/c/6671a46144f880c5a167930ebb14c12f3d059fe9 (opens in a new tab)
- git.kernel.org/stable/c/6676b6063440561db600494049ce7ffb695c8cc4 (opens in a new tab)
- git.kernel.org/stable/c/a7ef78a2c536242ccb7a4429da01580b2409bb24 (opens in a new tab)
- ubuntu.com/security/notices/USN-8726-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8727-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-1 (opens in a new tab)