Skip to main content
VulnerabilityPublished Updated

CVE-2026-53249: Linux kernel · ipv4: restrict IPOPT_SSRR and IPOPT_LSRR options

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 5.5 Medium · fixed in 5.15.0-1117.124~20.04.1 : update Linux kernel when convenient.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.15.0-1117.124~20.04.1, 5.15.0-1123.132~20.04.1, 5.15.0-1122.131~20.04.1 +68
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-31.31
Fixed in
  • 7.0.0-31.31
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1012.12
Fixed in
  • 7.0.0-1012.12
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1014.14
Fixed in
  • 7.0.0-1014.14
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threatsAffected
  • 7.0.0-1003.3 – 7.0.0-1016.16
9 affected builds
Fixed in–
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1011.11
Fixed in
  • 7.0.0-1011.11
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1006.7
Fixed in
  • 7.0.0-1006.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been released in Linux kernel versions 5.15.0-1111.115~20.04.1 and later. Users should upgrade affected Linux kernel versions to these fixed releases or later to remediate this vulnerability. No additional mitigation is required as the fix restricts the use of LSRR and SSRR options to privileged users only.

Description

A vulnerability in the Linux kernel IPv4 implementation allowed unprivileged users to set Loose Source and Record Route (LSRR) and Strict Source and Record Route (SSRR) IP options, potentially enabling routing of packets through attacker-controlled nodes to leak protocol information. This issue has been resolved by restricting these options to users with CAP_NET_RAW capability. The vulnerability affects specific Linux kernel versions and has been fixed in later releases.

References

Community reviews

Loading reviews…