Skip to main content
VulnerabilityPublished Updated

CVE-2026-53283: Linux kernel · iommu/amd: Bounds-check devid in __rlookup_amd_iommu()

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 5.5 Medium · patch available : update Linux kernel when convenient.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux@7.0.0-28.28?arch=source&distro=resoluteOther threatsAffected
  • 6.17.0-5.5 – 7.0.0-28.28
18 affected builds
Fixed in–
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws@7.0.0-1008.8?arch=source&distro=resoluteOther threatsAffected
  • 6.17.0-1002.2 – 7.0.0-1008.8
9 affected builds
Fixed in–
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure@7.0.0-1009.9?arch=source&distro=resoluteOther threatsAffected
  • 6.17.0-1003.3 – 7.0.0-1009.9
10 affected builds
Fixed in–
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde@7.0.0-1008.8?arch=source&distro=resoluteOther threatsAffected
  • 7.0.0-1003.3 – 7.0.0-1008.8
4 affected builds
Fixed in–
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp@7.0.0-1008.8?arch=source&distro=resoluteOther threatsAffected
  • 6.17.0-1002.2 – 7.0.0-1008.8
9 affected builds
Fixed in–
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke@7.0.0-1003.4?arch=source&distro=resoluteOther threatsAffected
  • =7.0.0-1002.3
  • =7.0.0-1003.4
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch fixing this vulnerability is available and was applied in Linux kernel version 6.18.22. Systems running affected versions should upgrade to 6.18.22 or later to resolve the issue. The vendor advisory from Ubuntu confirms the fix and recommends applying the update. No additional mitigations are required once the patch is applied.

Description

A vulnerability in the Linux kernel's AMD IOMMU driver was fixed in version 6.18.22. The flaw involved an out-of-bounds array access in the __rlookup_amd_iommu() function, which could cause a general protection fault (GPF) during boot on affected systems, such as certain Google Compute Engine VMs. The issue arose after a change in memory allocation for the rlookup_table, leading to invalid memory dereference. The fix adds proper bounds checking to prevent this fault, allowing affected VMs to boot cleanly.

References

Community reviews

Loading reviews…