CVE-2026-53317: Linux kernel · wifi: mt76: mt7921: Place upper limit on station AID
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 5.5 Medium · fixed in 7.0.0-28.28~24.04.1 : update Linux kernel when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.0.0-28.28~24.04.1, 7.0.0-1016.16~24.04.1, 7.0.0-28.28 +12
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 26 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and fixed versions include 7.0.0-28.28 and later builds as listed in the established facts. Users should upgrade to these fixed Linux kernel versions to remediate the issue. No additional mitigation is required beyond applying the official fix.
Description
A vulnerability in the Linux kernel's mt76 wifi driver for mt7921 hardware caused firmware crashes when a station was configured with an Association ID (AID) over 20. This was due to hostapd software allocating station AIDs starting at 65, which is outside the expected range, leading to firmware instability on AP interfaces. The issue affects certain Linux kernel versions prior to 7.0.0-28.28 and related builds. A fix has been released that places an upper limit on station AIDs to prevent such crashes.
References
- ubuntu.com/security/CVE-2026-53317 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-53317 (opens in a new tab)
- git.kernel.org/linus/4d0bf21e3e20619d51d06c0c36207aabab8b712c (opens in a new tab)
- git.kernel.org/stable/c/1a4b802afe15c5b33b2dcb37a594aba2fa215d52 (opens in a new tab)
- git.kernel.org/stable/c/35835ff71e6e618155578b8e3905597edd5f601c (opens in a new tab)
- git.kernel.org/stable/c/4d0bf21e3e20619d51d06c0c36207aabab8b712c (opens in a new tab)
- git.kernel.org/stable/c/6dbe70f9ef14d8ac1c24bf19fd9510978a3ab952 (opens in a new tab)
- ubuntu.com/security/notices/USN-8566-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8568-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8569-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8593-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8603-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8618-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8663-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8664-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-3 (opens in a new tab)