Skip to main content
VulnerabilityPublished Updated

CVE-2026-53330: Linux kernel · drm/amd/display: Fix out-of-bounds read in dp_get_eq_aux_rd_interval()

Affects Linux kernelSource GCVE Database

0
Authoritative record:CVE-2026-53330

Not known to be exploited · CVSS 7.1 High · fixed in 7.0.0-31.31~24.04.1 : patch Linux kernel soon.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.0-31.31~24.04.1, 7.0.0-1018.18~24.04.1, 6.8.0-1036.39 +14
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-31.31
Fixed in
  • 7.0.0-31.31
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1012.12
Fixed in
  • 7.0.0-1012.12
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1014.14
Fixed in
  • 7.0.0-1014.14
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threatsAffected
  • 7.0.0-1003.3 – 7.0.0-1016.16
9 affected builds
Fixed in–
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1011.11
Fixed in
  • 7.0.0-1011.11
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1006.7
Fixed in
  • 7.0.0-1006.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and has been released in multiple linux-hwe-edge kernel versions starting from 7.0.0-31.31~24.04.1 and related builds. Users should update to these fixed kernel versions to remediate the vulnerability. No additional mitigation actions are specified or required beyond applying the official patches.

Description

A vulnerability in the Linux kernel's AMD display driver (drm/amd/display) caused an out-of-bounds read due to improper array sizing in the dp_get_eq_aux_rd_interval() function. The aux_rd_interval array was declared with 7 elements but could be indexed up to 8, leading to an out-of-bounds read. This issue has been fixed by increasing the array size to accommodate the full range of valid repeater counts as defined by the DisplayPort specification. The vulnerability affects specific linux-hwe-edge kernel versions and has been addressed in later fixed versions.

References

Community reviews

Loading reviews…