CVE-2026-53550: nodeca js-yaml · Inefficient Algorithmic Complexity
Affects nodeca js-yamlSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 4.2.0 or 3.15.0 when convenient.
Data as of 5 Nov 2026, 23:24 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.2.0, 3.15.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 22 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade js-yaml to 4.2.0 or 3.15.0; js-yaml to 4.2.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| nodecajs-yaml | Affected
| Fixed in
|
| nodecajs-yaml | Affected
| Fixed in
|
npmjs-yamlpkg:npm/js-yamlOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in js-yaml versions 4.2.0 and 3.15.0. Users should upgrade to at least version 4.2.0 or 3.15.0 to remediate this issue. Patch status is confirmed by the version information in the description. No additional mitigations are specified.
Description
js-yaml is a JavaScript YAML parser and dumper. Prior to 4.2.0 and 3.15.0, a crafted YAML document can trigger algorithmic CPU exhaustion in js-yaml merge-key processing (<<) by repeating the same alias many times in a merge sequence. This causes quadratic parse-time behavior relative to input size and can block a Node.js worker/event loop for seconds with a relatively small payload (tens of KB), resulting in denial of service. The issue is in merge handling inside lib/loader.js. This vulnerability is fixed in 4.2.0 and 3.15.0.