CVE-2026-53713: envoyproxy gateway · Improper Input Validation
Affects envoyproxy gatewaySource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical : upgrade to 1.8.1 or 1.7.4 as a priority.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Limited control over the software or limited information exposure
CISA SSVC assessment, 2026-09-16.
- Patch
- Available – fixed in 1.8.1, 1.7.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 14 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade envoyproxy gateway to 1.8.1 or 1.7.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| envoyproxygateway | Affected
| Fixed in
|
| envoyproxygateway | Affected
| Fixed in
|
AI-suggested
Upgrade Envoy Gateway to version 1.7.4 or later, or 1.8.1 or later, where this vulnerability is fixed. No other mitigation is indicated by the vendor advisory. Applying the official patch is the recommended remediation.
Description
CVE-2026-53713 is a critical vulnerability in Envoy Gateway prior to versions 1.7.4 and 1.8.1. It involves improper input validation in the Lua validator component, where redundant path separators are not collapsed before security checks. This flaw allows crafted Lua code submitted via EnvoyExtensionPolicy to read arbitrary files from the gateway controller pod, potentially exposing sensitive Kubernetes service-account tokens, TLS certificates, and environment data. The vulnerability is fixed in versions 1.7.4 and 1.8.1.
References
- github.com/envoyproxy/gateway/security/advisories/GHSA-wcrf-9vrr-854f (opens in a new tab)
- github.com/envoyproxy/gateway/pull/9171 (opens in a new tab)
- github.com/envoyproxy/gateway/pull/9172 (opens in a new tab)
- github.com/envoyproxy/gateway/pull/9173 (opens in a new tab)
- github.com/envoyproxy/gateway/commit/5a78db82b7cf4fc5bebbeda2c50952892038a464 (opens in a new tab)
- github.com/envoyproxy/gateway/commit/96e2b750868a459ace4b8b68e6a6e4fb0152b9b7 (opens in a new tab)
- github.com/envoyproxy/gateway/commit/b4737180c7e597490c6363075c565fa8cf24eead (opens in a new tab)
- github.com/envoyproxy/gateway/releases/tag/v1.7.4 (opens in a new tab)
- github.com/envoyproxy/gateway/releases/tag/v1.8.1 (opens in a new tab)