Skip to main content
VulnerabilityPublished

CVE-2026-54036: danny-avila LibreChat · Missing Authentication

Affects danny-avila LibreChatSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 0.8.4-rc1 when convenient.

Data as of 6 Nov 2026, 23:24 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.8.4-rc1
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade danny-avila LibreChat to 0.8.4-rc1.

Affected software

ProductAffectedFixed in
danny-avilaLibreChatAffected
  • <0.8.4-rc1
Fixed in
  • 0.8.4-rc1
GitHubdanny-avila/LibreChatpkg:github/danny-avila/LibreChatOther threatsAffected
  • =0.8.4-rc1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade LibreChat to version 0.8.4-rc1 or later, where this vulnerability is fixed. There is no official vendor advisory specifying alternative mitigations or temporary fixes. Until patched, restrict access to authenticated sessions and monitor for suspicious session activity to reduce risk.

Description

LibreChat is an enhanced ChatGPT clone that supports multiple AI providers. Prior to 0.8.4-rc1, the GET /api/auth/2fa/enable endpoint can be called by an authenticated user (or attacker with a stolen session) even when 2FA is already fully enabled on the account. This endpoint overwrites the existing TOTP secret, generates new backup codes, and sets twoFactorEnabled to false — all without requiring any TOTP or backup code verification. An attacker with a valid session token can completely take over a victim's 2FA, locking the legitimate user out of their own two-factor authentication. This vulnerability is fixed in 0.8.4-rc1.

References

Community reviews

Loading reviews…