Skip to main content
VulnerabilityPublished

CVE-2026-5412: Canonical Juju · Improper Authorization

Affects Canonical JujuSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.9 Critical : upgrade to 3.6.21 or 2.9.57 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
9.9Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.6.21, 2.9.57
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Juju and juju to 3.6.21 or 2.9.57.

Affected software

ProductAffectedFixed in
CanonicalJujuAffected
  • >=3.6.0 <3.6.21
Fixed in
  • 3.6.21
CanonicalJujuAffected
  • >=2.9.0 <2.9.57
Fixed in
  • 2.9.57
GitHubjuju/jujupkg:github/juju/jujuOther threatsAffected
  • =2.9.0
  • =3.6.0
Fixed in–
GitHubjujupkg:github/jujuOther threatsAffected
  • >=2.9.0 <2.9.57
  • >=3.6.0 <3.6.21
Fixed in
  • 2.9.57
  • 3.6.21

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available by upgrading Juju to version 2.9.57 or 3.6.21 or later. Patch status is not explicitly confirmed beyond the stated fixed versions, so checking the vendor advisory for the latest remediation guidance is recommended.

Description

CVE-2026-5412 is a critical improper authorization vulnerability in Canonical Juju versions prior to 2.9.57 and 3.6.21. It allows an authenticated low-privileged user to call the CloudSpec API method in the Controller facade to extract cloud credentials used to bootstrap the controller. This exposure of sensitive credentials can lead to complete compromise of confidentiality, integrity, and availability of the affected system. The issue is fixed in Juju versions 2.9.57 and 3.

References

Community reviews

Loading reviews…